0
"require": {
        "segmentio/analytics-php": "^1.5",
    }

This code is there in composer json, when i have composer update the segmentio lib version changed from 1.5 to 1.7 not sure why.

1
  • any thoughts on this ?
    – devhs
    May 6, 2021 at 12:15

1 Answer 1

2

require means, the package you are installing require this package: please check link

The ^ in module version represent version number up to it can be update.

For example ^1.5 is equivalent to >=1.5 <2.0.0

For more information see link

3
  • Thanks for the answer can you please answer if their any possibility to override library php file in module such as /Magento2/vendor/segmentio/analytics-php/lib/Segment/QueueConsumer.php ?
    – devhs
    May 6, 2021 at 12:28
  • welcome @devhs. it is a third party lib not a Magento 2 standard module.I not aware about overriding third party lib. I will check and try it.
    – Pawan
    May 6, 2021 at 12:35
  • Thanks for sharing your thoughts, i need to check if it can be override or not
    – devhs
    May 6, 2021 at 12:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.