1

I have Magento working in a cPanel, but I need to migrate in to Docker.

I kept the same version of PHP (7.1.33) and also MySQL (5.7).

Installed the extensions:

mysqli, pdo_mysql, mcrypt, intl, xsl, gd, bcmath, soap, zip, sockets, sqlsrv, pdo_sqlsrv.

Run the commands:

rm -rf var/cache/* var/page_cache/* var/generation/*
php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento deploy:mode:show
php bin/magento setup:static-content:deploy

However when I try to access the page I get an ERR_EMPTY_RESPONSE and Apache consumes all the resources of the machine. 8GB RAM & 8 threads.

Magento version 2.2.6. Where dit I go wrong?

Thanks!

4
  • Enable all Cache and see if that helps. bin/magento cache:enable – Adarsh Khatri May 5 at 0:26
  • Thanks for help, but some problem www-data@f4d1da4e2e84:~/html$ php -d memory_limit=-1 bin/magento cache:enable Killed – Rafael Arcanjo May 7 at 10:24
  • Looks like you have memory limit, try editing the config file directly and save it. File: app/etc/env.php, make cache_types all to 1. – Adarsh Khatri May 9 at 23:27
  • The memory limit is the RAM limit Allowed memory size of 792723456 bytes exhausted (tried to allocate 262144 bytes) – Rafael Arcanjo May 11 at 16:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.