2

If I add a media node to the page builder and try to select an image from the gallery, then nothing happens. Normally the gallery should load.

enter image description here

I get this in the network console

https://company.de/backendlogin/cms/wysiwyg_images/index/key/095a7a5f8e56bbf90e8337f93695509fa2e57b0863e15518e17b60f110f3779b/target_element_id/BCP3YMC/store/1/type/image/?isAjax=true&current_tree_path=d3lzaXd5Zw--
    
{"error":true,"message":"You entered an invalid Secret Key. Please refresh the page."}

enter image description here

I flushed the cache and deleted all browser cookies, but it does not help.

The project is in production mode.

2
  • Could you fix this issue? I'm facing the same problem. May 27 at 19:59
  • 1
    @MarceloRodovalho, Yes, I added an answer.
    – Black
    May 28 at 7:58
2

There is a patch that should resolve the reported issue available in the Magento Quality Patches package (MQP).

Patch Summary:

Page builder config is now cached per user session if secret key is enabled in backend URLs. (for v2.4.2)

To apply the patch using MQP, please follow the steps below:

  1. Install the MQP package: ./composer require magento/quality-patches
  2. Apply the patch: ./vendor/bin/magento-patches apply MDVA-32133
  3. Clean the cache: ./bin/magento cache:clean

Additional documentation on how to use the MQP tool.

https://devdocs.magento.com/cloud/project/project-patch.html

1
0

May be your secret key got expired, please use postman to test if your API and secret key is working properly there and you are getting proper JSON response.

4

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.