0

I don't know if it's a problem with my magento(magento 2.4.1) or with my server

I found this errors in log file:

1-main.CRITICAL: Lo sentimos, algo salió mal. Encontrarás más información en el registro de errores. {“report_id”:“5a53758f00c8f6836c7b809a696d29418a204bf7755566fbca48b128872efe73”,“exception”:"[object] (Magento\Framework\Exception\LocalizedException(code: 0): Lo sentimos, algo salió mal. Encontrarás más información en el registro de errores. at /bitnami/magento/app/code/Mageplaza/LayeredNavigation/Model/ResourceModel/Fulltext/Collection.php:500)"} []

(this error i dont know why)

2- main.CRITICAL: No alive nodes found in your cluster {“exception”:"[object] (Elasticsearch\Common\Exceptions\NoNodesAvailableException(code: 0): No alive nodes found in your cluster at /bitnami/magento/vendor/elasticsearch/elasticsearch/src/Elasticsearch/ConnectionPool/StaticNoPingConnectionPool.php:50)"} []

(i know this error is when elasticsearch is stopped)

3-main.CRITICAL: Sin identidad con id = 151 {“report_id”:“a159db1bdbeb6bae1fdbd5a54f75249bc8b12e7cf716bfd718c6e05227dab1f5”,“exception”:"[object] (Magento\Framework\Exception\NoSuchEntityException(code: 0): Sin identidad con id = 151 at /bitnami/magento/vendor/magento/framework/Exception/NoSuchEntityException.php:50)"} []

(this happens because magento is looking for a category that no longer exists)

4-main.CRITICAL: The stock item was unable to be saved. Please try again. {“exception”:"[object] (Magento\Framework\Exception\CouldNotSaveException(code: 0): The stock item was unable to be saved. Please try again. at /bitnami/magento/vendor/magento/module-catalog-inventory/Model/Stock/StockItemRepository.php:187, Magento\Framework\Exception\LocalizedException(code: 0): Could not ping search engine: No alive nodes found in your cluster at /bitnami/magento/vendor/magento/module-elasticsearch/Model/Adapter/Elasticsearch.php:166)"} []

(i see this error happens when elasticsearch is stopped)

5-main.CRITICAL: SQLSTATE[HY000] [2002] Connection refused {“report_id”:“1b81cb1bc304cb27c49162710beda39c5b5776967e3451cd02091d3d63a2d063”,“exception”:"[object] (Zend_Db_Adapter_Exception(code: 2002): SQLSTATE[HY000] [2002] Connection refused at /bitnami/magento/vendor/magento/zendframework1/library/Zend/Db/Adapter/Pdo/Abstract.php:144, PDOException(code: 2002): SQLSTATE[HY000] [2002] Connection refused at /bitnami/magento/vendor/magento/zendframework1/library/Zend/Db/Adapter/Pdo/Abstract.php:128)"} []

(this error when mariadb is stopped)

thank you for your help

2
  • how much RAM on your server? and disk space? – MagenX Apr 23 at 20:20
  • RAM: total:6.8Gi used :5.6Gi free:624Mi and DISK SPACE: Size:30G used:20G free:8.1G – Paty Gallardo Apr 23 at 21:31
0

you need to check elaticsearch log to get exact error message.

but usually this is problem with low memory, incorrect heap size or disk space.

check you have RAM available and enough heap configured, for small systems it can be pretty minimal:

/etc/elasticsearch/jvm.options

## JVM configuration

################################################################
## IMPORTANT: JVM heap size
################################################################
##
## You should always set the min and max JVM heap
## size to the same value. For example, to set
## the heap to 4 GB, set:
##
## -Xms512m
## -Xmx512m
##
## See https://www.elastic.co/guide/en/elasticsearch/reference/current/heap-size.html
## for more information
##
################################################################

# Xms represents the initial size of total heap space
# Xmx represents the maximum size of total heap space

-Xms512m
-Xmx512m

disk space check for elasticsearch:

https://www.elastic.co/guide/en/elasticsearch/reference/current/modules-cluster.html#disk-based-shard-allocation

disable checks:

curl -XPUT -H "Content-Type: application/json" http://localhost:9200/_cluster/settings -d '{ "transient": { "cluster.routing.allocation.disk.threshold_enabled": false } }'

add to elasticsearch config:

cluster.routing.allocation.disk.threshold_enabled:  false
0
0

I found the solution,if someone has the same issue the problems was a lot of idle php-fpm idle child processes and the SOLUTION WAS set the max_children setting in the file "pool.conf" :

pm.max_children = 30 pm.start_servers = 15 pm.min_spare_servers = 15 pm.max_spare_servers = 25 pm.max_requests = 500

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.