1

{"error":{"root_cause":[{"type":"cluster_block_exception"enter image description here

1 Answer 1

3

go to "Cache Management" and first disable all cache and after enable it so this error is remove from setup:upgrade comand list

enter image description here

Run THis Comman on Terminal:

curl -XPUT -H "Content-Type: application/json" http://localhost:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

Restart Elasticsearch

if not working please do below step run command 1-> curl -XPUT -H "Content-Type: application/json" http://localhost:9200/_cluster/settings -d '{ "transient": { "cluster.routing.allocation.disk.threshold_enabled": false } }' 2-> curl -XPUT -H "Content-Type: application/json" http://localhost:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

After running the above codes, run below mentioned commands

  1. php bin/magento setup:upgrade
  2. php bin/magento setup:static-content:deploy
  3. php bin/magento indexer:reindex
  4. php bin/magento cache:clean
1
  • Thank you, worked for me!
    – cjohansson
    Dec 15, 2023 at 13:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.