0

I did upgrade my Magento version 2.3.4 to v2.4.2 Then activate ElasticSarch and upgrade the composer

then the site working for me. Admin and Frontend have appeared without any error.

but showing a warning on my AdminDashboard [![enter image description here][1]][1]

When I run bin/magento indexer:reindex it showing

Catalog Search index process unknown error: {"error":"MapperParsingException[No handler for type [text] declared on field [_search]]","status":400}

[![enter image description here][2]][2]

I did try this comments but still the error is there

php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento setup:static-content:Deploy -f

sudo chmod -R 777 var/ pub/ generated/ vendor/

Help me to resolve this issue. [1]: https://i.stack.imgur.com/FSiUl.png [2]: https://i.stack.imgur.com/CJ6GF.png

1
  • What elastic version you have configured? Apr 9, 2021 at 12:16

1 Answer 1

0

Please make sure your ElasticServer is up and running. You can use the following CLI commands to test the availability and the outcome:

curl localhost:9200

Pleas keep in mind that the ElasticSuite ^2.6 supports ElasticSearch 6.x so use it. A lot of things got fixed enhanced on that version. Also ElasticSuite ^2.6 is not compatible with ElasticSearch 2.x.

Installing ElasticSearch 6.x For a detailed instruction ""tutorial"" please refer to the official Smile_Elasticsuite documentary to get everything correct https://github.com/Smile-SA/elasticsuite/wiki/ServerConfig-5.x#installing-elasticsearch After you installed and configured ElasticSearch and ElasticSuite do the following steps: php bin/magento setup:upgrade

php bin/magento setup:di:compile

php bin/magento setup:static-content:deploy

Clear magento Cache

2
  • one of the main issues is ElasticSearch did not work properly because of the Java version issue. And also Re-index issue was there, it is due to the elasticSearch version issue. v6 to v5 will work fine
    – Vipin R V
    Apr 20, 2021 at 10:48
  • You must install and configure Elasticsearch before upgrading to Magento 2.4.x. Refer to the System Requirements for specific version information: devdocs.magento.com/guides/v2.4/install-gde/… Magento does not support Elasticsearch 2.x, 5.x, and 6.x. Apr 22, 2021 at 8:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.