0

Hi am trying to setup vuestorefront locally over windows 10 and it compiled successfully but on frontend it showing something went wrong

Something went wrong ... We've noticed Internal Server Error while rendering this request. If you need an assistance you can drop us a line on a contact page

also am getting this error in console

{"code":500,"result":{"root_cause":[{"type":"illegal_argument_exception","reason":"request [/vue_storefront_catalog/attribute/_search] contains unrecognized parameter: [_source_include] -> did you mean any of [_source_includes, _source_excludes]?"}],"type":"illegal_argument_exception","reason":"request [/vue_storefront_catalog/attribute/_search] contains unrecognized parameter: [_source_include] -> did you mean any of [_source_includes, _source_excludes]?"}}

searchAdapter.ts:78 GET http://localhost:8080/api/catalog/vue_storefront_catalog/attribute/_search?_source_include=activity%2Cattribute_code%2Cattribute_id%2Cdefault_frontend_label%2Cdefault_value%2Centity_type_id%2Cfrontend_input%2Cfrontend_label%2Cid%2Cis_user_defined%2Cis_visible_on_front%2Cis_visible%2Cis_comparable%2Coptions%2Ctier_prices&from=0&request=%7B%22query%22%3A%7B%22bool%22%3A%7B%22filter%22%3A%7B%22terms%22%3A%7B%22attribute_code%22%3A%5B%22color%22%2C%22erin_recommends%22%2C%22price%22%2C%22size%22%2C%22activity%22%2C%22final_price%22%2C%22id%22%2C%22image%22%2C%22name%22%2C%22new%22%2C%22original_price%22%2C%22original_price_incl_tax%22%2C%22price_incl_tax%22%2C%22product_links%22%2C%22sale%22%2C%22sku%22%2C%22special_price%22%2C%22special_price_incl_tax%22%2C%22special_from_date%22%2C%22special_to_date%22%2C%22status%22%2C%22tax_class_id%22%2C%22tier_prices%22%2C%22type_id%22%2C%22url_path%22%2C%22url_key%22%5D%7D%7D%7D%7D%7D&size=150&sort= 500 (Internal Server Error)

0

You did not provide essential details. Fortunately, I know what's wrong.

You've configured your application to use a different version of Elasticsearch than you installed. E.g. you configured it to use 5.6 version but you installed version 7.x.

In 6 or 7 version of Elasticsearch there were breaking changes - one of them is change the name of _source_include property to the _source_includes.

Just after you unify version & configuration. It will work fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.