1

I have an error when attempting to search for a keyword in my custom table

See error here

In Network tab, i have a call to

https://mylocalsite.local/admin/mui/index/render/?namespace=my_grid&search=123&filters%5Bplaceholder%5D=true&paging%5BpageSize%5D=20&paging%5Bcurrent%5D=1&sorting%5Bfield%5D=po_date&sorting%5Bdirection%5D=asc&isAjax=true

which returns

{"error":"UI component could not be rendered because of system exception","errorcode":"42"}

And in the exception.log i have:

main.CRITICAL: SQLSTATE[42S22]: Column not found: 1054 Unknown column 'fulltext' in 'where clause', query was: SELECT COUNT(*) FROM purchase_order AS main_table INNER JOIN admin_user AS u ON u.user_id = main_table.created_by WHERE (((fulltext = 'abc')))

In my grid XML declaration i have the following:

...
<dataSource name="my_grid_data_source">
    <argument name="dataProvider" xsi:type="configurableObject">
        <argument name="data" xsi:type="array">
            <item name="config" xsi:type="array">
                <item name="update_url" xsi:type="url" path="mui/index/render"/>
                <item name="storageConfig" xsi:type="array">
                    <item name="indexField" xsi:type="string">id</item>
                </item>
            </item>
        </argument>
        <argument name="class" xsi:type="string">Vendor\Module\Ui\DataProvider\Module\GridDataProvider</argument>
        <argument name="name" xsi:type="string">my_grid_data_source</argument>
        <argument name="primaryFieldName" xsi:type="string">id</argument>
        <argument name="requestFieldName" xsi:type="string">id</argument>
    </argument>
    <argument name="data" xsi:type="array">
        <item name="js_config" xsi:type="array">
            <item name="component" xsi:type="string">Magento_Ui/js/grid/provider</item>
        </item>
    </argument>
</dataSource>
...

<listingToolbar>
    ...
    <filterSearch name="fulltext"></filterSearch>
    ...
</listingToolbar>

I have the database indexes in place (created from the install script) see full text indexes here

However, when i try to search for something, i am getting that error i posted in the beginning of this question. What am i missing? Thank you.

7
  • you can open console window or network tab in developer tool of your browsers to see what exactly the error is. or try looking for errors in var/log folder – Jimmy Apr 7 at 1:49
  • Hi Jimmy, i updated my answer with the errors from network tab and logs. Any idea what's wrong? – Robert Apr 7 at 6:43
  • I don't know why you have this, maybe you could try remove all the fields related to the error, in this case fulltext, try removing it, if the error went away, then we know the culprit, focus on that to see why it's wrong – Jimmy Apr 7 at 9:05
  • I have no field called "fulltext", that must be from the <filterSearch name="fulltext"></filterSearch>, i don't have any other reference to "fulltext" – Robert Apr 7 at 10:08
  • yup, try removing it. Then try with different functions in the grid such as sort, paging, filter with other fields other than text. – Jimmy Apr 7 at 10:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.