0

I was installing Magento on my pc on xampp. First I had a lot of errors worked through it but now am getting the message below would please advise. Thank you in advance

PHP Parse error:  syntax error, unexpected 'protected' (T_PROTECTED) in C:\xampp
\htdocs\magento24\vendor\magento\framework\Image\Adapter\Gd2.php on line 108

Parse error: syntax error, unexpected 'protected' (T_PROTECTED) in C:\xampp\htdo
cs\magento24\vendor\magento\framework\Image\Adapter\Gd2.php on line 108
PHP Fatal error:  Uncaught Exception: User Error: Some transactions have not bee
n committed or rolled back in C:\xampp\htdocs\magento24\vendor\magento\framework
\DB\Adapter\Pdo\Mysql.php on line 4050 in C:\xampp\htdocs\magento24\vendor\magen
to\framework\App\ErrorHandler.php:61
Stack trace:
#0 [internal function]: Magento\Framework\App\ErrorHandler->handler(256, 'Some t
ransactio...', 'C:\\xampp\\htdocs...', 4050, Array)
#1 C:\xampp\htdocs\magento24\vendor\magento\framework\DB\Adapter\Pdo\Mysql.php(4
050): trigger_error('Some transactio...', 256)
#2 [internal function]: Magento\Framework\DB\Adapter\Pdo\Mysql->__destruct()
#3 {main}
  thrown in C:\xampp\htdocs\magento24\vendor\magento\framework\App\ErrorHandler.
php on line 61

Fatal error: Uncaught Exception: User Error: Some transactions have not been com
mitted or rolled back in C:\xampp\htdocs\magento24\vendor\magento\framework\DB\A
dapter\Pdo\Mysql.php on line 4050 in C:\xampp\htdocs\magento24\vendor\magento\fr
amework\App\ErrorHandler.php:61
Stack trace:
#0 [internal function]: Magento\Framework\App\ErrorHandler->handler(256, 'Some t
ransactio...', 'C:\\xampp\\htdocs...', 4050, Array)
#1 C:\xampp\htdocs\magento24\vendor\magento\framework\DB\Adapter\Pdo\Mysql.php(4
050): trigger_error('Some transactio...', 256)
#2 [internal function]: Magento\Framework\DB\Adapter\Pdo\Mysql->__destruct()
#3 {main}
  thrown in C:\xampp\htdocs\magento24\vendor\magento\framework\App\ErrorHandler.
php on line 61
1
  • This error comes when you don't have compatible PHP version. I suggest you go with docker or sub-linux system
    – Jimmy
    Commented Mar 26, 2021 at 3:28

1 Answer 1

0

I sorted the issue by downgrading to php 7.4 but now I am facing this new one

in compat.php line 1927: this is not implemented, as it is not possible to implement argon2i with acceptable performance in pure-php

am using docker for my axelor erp

thanks

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.