0

I´m with a 4Gb RAM with 1Gb SWAP at Cloudways and try to upgrade my Magento from 2.4.0 to 2.4.1 following this procedure: https://forums.envato.com/t/how-to-upgrade-magento-version-from-2-4-0-to-2-4-1/340406

For that I installed and use Composer 1. My PHP configuration are with 4Gb limit, and 6000s limit time.

After run composer update I'm receiving this erros bellow. Any ideia how can I solve that?

Thank you!

public_html$ /home/master/composer update Loading composer repositories with package information Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2 Updating dependencies (including require-dev) Package operations: 19 installs, 270 updates, 6 removals

  • Removing psr/simple-cache (1.0.1) Removing Psr/SimpleCache
  • Removing league/mime-type-detection (1.5.1) Removing League/MimeTypeDetection
  • Removing league/flysystem (1.1.3) Removing League/Flysystem
  • Removing doctrine/inflector (v1.1.0) Removing Doctrine/Inflector
  • Removing doctrine/cache (1.10.2) Removing Doctrine/Cache
  • Removing cache/cache (0.4.0) Removing Cache/Cache
  • Updating symfony/process (v4.4.16 => v4.4.20): Downloading (100%)
  • Updating symfony/polyfill-php80 (v1.20.0 => v1.22.1): Downloading (100%)
  • Updating symfony/polyfill-php73 (v1.20.0 => v1.22.1): Downloading (100%)
  • Updating symfony/polyfill-mbstring (v1.20.0 => v1.22.1): Downloading (100%)
  • Updating symfony/console (v4.4.16 => v4.4.20): Downloading (100%)
  • Updating symfony/polyfill-ctype (v1.20.0 => v1.22.1): Downloading (100%)
  • Updating symfony/finder (v5.1.8 => v5.2.4): Downloading (100%)
  • Updating symfony/filesystem (v5.1.8 => v5.2.4): Downloading (100%)
  • Updating seld/jsonlint (1.8.2 => 1.8.3): Downloading (100%)
  • Updating composer/xdebug-handler (1.4.4 => 1.4.5): Downloading (100%)
  • Updating composer/spdx-licenses (1.5.4 => 1.5.5): Downloading (100%)
  • Updating composer/semver (1.7.1 => 1.7.2): Downloading (100%)
  • Updating composer/ca-bundle (1.2.8 => 1.2.9): Downloading (100%)
  • Updating composer/composer (1.10.6 => 1.10.19): Downloading (100%)
  • Updating magento/magento-composer-installer (0.1.13 => 0.2.0): Downloading (100%)
  • Updating magento/composer-root-update-plugin (1.0.0 => 1.1.0): Downloading (100%) Installing "magento/composer-root-update-plugin: 1.1.0" for the Web Setup Wizard Loading composer repositories with package information Warning from https://repo.packagist.org: You are using an outdated version of Composer. Composer 2 is now available and you should upgrade. See https://getcomposer.org/2 Updating dependencies Package operations: 24 installs, 0 updates, 0 removals
  • Installing react/promise (v2.8.0): Downloading (100%)
    proc_open(): fork failed - Cannot allocate memory The archive may contain identical file names with different capitalization (which fails on case insensitive filesystems) Unzip with unzip command failed, falling back to ZipArchive class Web Setup Wizard installation of "magento/composer-root-update-plugin: 1.1.0" failed proc_open(): fork failed - Cannot allocate memory
  • Updating magento/module-ui (101.2.0 => 101.2.1): The following exception is caused by a lack of memory or swap, or not having swap configured Check https://getcomposer.org/doc/articles/troubleshooting.md#proc-open-fork-failed-errors for details

PHP Warning: proc_open(): fork failed - Cannot allocate memory in phar:///home/master/composer/vendor/symfony/console/Application.php on line 952

Warning: proc_open(): fork failed - Cannot allocate memory in phar:///home/master/composer/vendor/symfony/console/Application.php on line 952 [ErrorException] proc_open(): fork failed - Cannot allocate memory

update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [--with-all-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] []...

(failed reverse-i-search)`': composer ^Cearcache

1
  • I restart the server and did the update. Everything goes fine. Anyone nows if I can use the same procedure to goes to 2.4.2? – Smarley Mar 21 at 20:15
0

This is a general warning of the composer. Once the composer is self-updated, the issue will be resolved. Run the below command: composer self-update

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.