0

How can i add the company to these Blocks on checkout Page?

show company in /checkout/#shipping

show company in /checkout/#payment

I ve tried to add these Information to:

enter image description here

But it will not be displayed. Example given:

<if args="visible()">
<text args="address().company"/>
<text args="address().prefix"/> <text args="address().firstname"/> <text args="address().middlename"/>
<text args="address().lastname"/> <text args="address().suffix"/><br/>
<text args="_.values(address().street).join(', ')"/><br/>
<text args="address().city "/>, <span text="address().region"></span> <text args="address().postcode"/><br/>
<text args="getCountryName(address().countryId)"/><br/>
<a if="address().telephone" attr="'href': 'tel:' + address().telephone" text="address().telephone"></a><br/>

<each args="data: address().customAttributes, as: 'element'">
    <text args="$parent.getCustomAttributeLabel(element)"/>
    <br/>
</each>

Please Help...

Other Shops are working:

enter image description here

2
  • There is no default company field for customer address data, have you added this database field yourself?
    – paj
    Mar 19 '21 at 9:44
  • it must be in magento 2.3.5-p2, it is shown in backend, you can see it in every form, but not in checkout...
    – Simon
    Mar 19 '21 at 21:14
0

AFAIK, there is a company field which you can show by enabling it in admin -> Stores -> Configuration -> Customers -> Customer Configuration -> Name and Address Options -> Show company.

Its display in the address forms is managed by Magento based on the configuration and you don't need to change anything.

3
  • Yes, got that, but it is not showing... In 2 of 3 Shops it is working, but not in this particular Shop...
    – Simon
    Mar 19 '21 at 10:30
  • oh... i'm thinking that the custom theme could be the issue? Mar 19 '21 at 12:01
  • could be, but the other shops got the same theme... Hard to find the difference, but i will try to find them if there
    – Simon
    Mar 19 '21 at 21:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.