0

after upgrading to 2.4.2 there is a problem with rest api

the url /index.php/rest/V1/modules responds with "File not found"
the url /rest/V1/modules works well

https://magento-560832-1812590.cloudwaysapps.com/index.php/rest/V1/modules

https://magento-560832-1812590.cloudwaysapps.com/rest/V1/modules

any idea?

Thank you

2 Answers 2

0

Go to phpmyadmin and run this query

SELECT * FROM `core_config_data` WHERE `path` LIKE '%rewrite%'

Change 'web/seo/use_rewrites' value to 1 if you want to exclude the index.php from the links. If you want to show index.php then change its value to 0.

Worked for me.

1
  • Refresh the cache after this process
    – Majid Ali
    Mar 12, 2021 at 11:32
0

solved setting the webroot to the pub/ directory

Thank you

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.