1

enter image description here

composer.json

{
    "name": "vendor/preorder",
    "description": "preorder",
    "type": "magento2-module",
    "version": "2.0.4",
    "license": [
        "OSL-3.0"
    ],
    "require": {
        "php": "~7.0.13||~7.1.0||~7.2.0||~7.3.0||~7.4.0"
    },
    "extra": {
        "installer-paths": {
            "app/code/Vendor/Preorder": ["vendor/preorder"]
        }
    },
    "repositories": [
        {
            "type": "composer",
            "url": "https://repo.magento.com"
        },
        {
            "type": "package",
            "package": {
                "name": "magento/marketplace-tools",
                "version": "dev-master",
                "source": {
                    "url": "https://github.com/magento/marketplace-tools",
                    "type": "git",
                    "reference": "origin/master"
                }
            }
        }
    ],
    "autoload": {
        "files": [
            "registration.php"
        ],
        "psr-4": {
            "Vendor\\Preorder\\": ""
        }
    }
}
2
  • Hi, could you post your report.json file? This provides valuable info
    – M. Sonah
    Commented May 19, 2021 at 16:46
  • @M.Sonah I'll post a file in few minutes Commented Jun 7, 2021 at 12:54

2 Answers 2

1

You should check your module first. See if it's actually breaking the cache.

Then you can always open a ticket for Marketplace staff to check it for you.

Here is the link to submit a ticket: https://marketplacesupport.magento.com/hc/en-us/requests

0

after escalating with Magento Engineering the solution is to using \Proxy for some command line codes.

Find your console type name in di.xml to make use of \Proxy in your argument

<type name="Maurisource\Lightspeed\Console\Command\LsSyncAll">
    <arguments>
        <argument name="lightspeedService" xsi:type="object">Maurisource\Lightspeed\Api\LightspeedServiceInterface\Proxy</argument>
        <argument name="state" xsi:type="object">Magento\Framework\App\State\Proxy</argument>
        <argument name="area" xsi:type="object">Magento\Framework\App\Area\Proxy</argument>
        <argument name="helper" xsi:type="object">Maurisource\Lightspeed\Helper\Data\Proxy</argument>
        <argument name="lockHelper" xsi:type="object">Maurisource\Lightspeed\Helper\Lock\Proxy</argument>
    </arguments>
</type>

Read the full guide on how I addressed this failure: https://maurisource.com/fixed-magento-marketplace-installation-varnish-test-results-failure/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.