0

i have upgraded magento 2.2.6 to magento 2.4.2 successfully But css is not getting reflected

enter image description here

I am able to login successfully. But not able to find the solution.

I have made dev/static/sign = 0
reindexing done
setup-content:deploy -f done

2

Check that your webserver serves the requests from the proper location. it should be referencing the <magento_proj_root>/pub folder as Document Root.

enter image description here

https://devdocs.magento.com/guides/v2.4/install-gde/tutorials/change-docroot-to-pub.html


Later edit

Also see this thread where I explained the settings for URLs when using a virtual host The requested URL /pub/ was not found on this server. - Magento .htaccess problem

5
  • i tried but still no output – jassi Mar 5 at 9:47
  • what's the format of your Magento URL? is it something like http://<domain.name>/magento or http://<domain.name>/<folder_name>? – Diana Botean Mar 5 at 10:00
  • http://<domain.name>/<folder_name> – jassi Mar 5 at 10:07
  • 1
    you will have to change your urls and remove the <folder_name> from it. go to the database or the admin and update the secure/unsecure url settings. also make sure the same url is used at webserver level in the 'servername' directive. see the update on my answer, i added a link there that might help you. – Diana Botean Mar 5 at 10:14
  • you're most welcome :) cheers! – Diana Botean Mar 5 at 11:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.