1

I have set up a localhost installation of Magento 2.4.2 community edition, now I am getting this error: 404 Not Found.

I've got elasticsearch installed, a mysql database created but I can't even access the mainpage of magento 2.4.2.

I have magento set up on /var/www/html/magento/ and this is my /etc/apache2/apache2.conf configuration:

# This is the main Apache server configuration file.  It contains the
# configuration directives that give the server its instructions.
# See http://httpd.apache.org/docs/2.4/ for detailed information about
# the directives and /usr/share/doc/apache2/README.Debian about Debian specific
# hints.
#
#
# Summary of how the Apache 2 configuration works in Debian:
# The Apache 2 web server configuration in Debian is quite different to
# upstream's suggested way to configure the web server. This is because Debian's
# default Apache2 installation attempts to make adding and removing modules,
# virtual hosts, and extra configuration directives as flexible as possible, in
# order to make automating the changes and administering the server as easy as
# possible.

# It is split into several files forming the configuration hierarchy outlined
# below, all located in the /etc/apache2/ directory:
#
#   /etc/apache2/
#   |-- apache2.conf
#   |   `--  ports.conf
#   |-- mods-enabled
#   |   |-- *.load
#   |   `-- *.conf
#   |-- conf-enabled
#   |   `-- *.conf
#   `-- sites-enabled
#       `-- *.conf
#
#
# * apache2.conf is the main configuration file (this file). It puts the pieces
#   together by including all remaining configuration files when starting up the
#   web server.
#
# * ports.conf is always included from the main configuration file. It is
#   supposed to determine listening ports for incoming connections which can be
#   customized anytime.
#
# * Configuration files in the mods-enabled/, conf-enabled/ and sites-enabled/
#   directories contain particular configuration snippets which manage modules,
#   global configuration fragments, or virtual host configurations,
#   respectively.
#
#   They are activated by symlinking available configuration files from their
#   respective *-available/ counterparts. These should be managed by using our
#   helpers a2enmod/a2dismod, a2ensite/a2dissite and a2enconf/a2disconf. See
#   their respective man pages for detailed information.
#
# * The binary is called apache2. Due to the use of environment variables, in
#   the default configuration, apache2 needs to be started/stopped with
#   /etc/init.d/apache2 or apache2ctl. Calling /usr/bin/apache2 directly will not
#   work with the default configuration.


# Global configuration
#

#
# ServerRoot: The top of the directory tree under which the server's
# configuration, error, and log files are kept.
#
# NOTE!  If you intend to place this on an NFS (or otherwise network)
# mounted filesystem then please read the Mutex documentation (available
# at <URL:http://httpd.apache.org/docs/2.4/mod/core.html#mutex>);
# you will save yourself a lot of trouble.
#
# Do NOT add a slash at the end of the directory path.
#
#ServerRoot "/etc/apache2"

#
# The accept serialization lock file MUST BE STORED ON A LOCAL DISK.
#
#Mutex file:${APACHE_LOCK_DIR} default

#
# The directory where shm and other runtime files will be stored.
#

DefaultRuntimeDir ${APACHE_RUN_DIR}

#
# PidFile: The file in which the server should record its process
# identification number when it starts.
# This needs to be set in /etc/apache2/envvars
#
PidFile ${APACHE_PID_FILE}

#
# Timeout: The number of seconds before receives and sends time out.
#
Timeout 300

#
# KeepAlive: Whether or not to allow persistent connections (more than
# one request per connection). Set to "Off" to deactivate.
#
KeepAlive On

#
# MaxKeepAliveRequests: The maximum number of requests to allow
# during a persistent connection. Set to 0 to allow an unlimited amount.
# We recommend you leave this number high, for maximum performance.
#
MaxKeepAliveRequests 100

#
# KeepAliveTimeout: Number of seconds to wait for the next request from the
# same client on the same connection.
#
KeepAliveTimeout 5


# These need to be set in /etc/apache2/envvars
User ${APACHE_RUN_USER}
Group ${APACHE_RUN_GROUP}

#
# HostnameLookups: Log the names of clients or just their IP addresses
# e.g., www.apache.org (on) or 204.62.129.132 (off).
# The default is off because it'd be overall better for the net if people
# had to knowingly turn this feature on, since enabling it means that
# each client request will result in AT LEAST one lookup request to the
# nameserver.
#
HostnameLookups Off

# ErrorLog: The location of the error log file.
# If you do not specify an ErrorLog directive within a <VirtualHost>
# container, error messages relating to that virtual host will be
# logged here.  If you *do* define an error logfile for a <VirtualHost>
# container, that host's errors will be logged there and not here.
#
ErrorLog ${APACHE_LOG_DIR}/error.log

#
# LogLevel: Control the severity of messages logged to the error_log.
# Available values: trace8, ..., trace1, debug, info, notice, warn,
# error, crit, alert, emerg.
# It is also possible to configure the log level for particular modules, e.g.
# "LogLevel info ssl:warn"
#
LogLevel warn

# Include module configuration:
IncludeOptional mods-enabled/*.load
IncludeOptional mods-enabled/*.conf

# Include list of ports to listen on
Include ports.conf


# Sets the default security model of the Apache2 HTTPD server. It does
# not allow access to the root filesystem outside of /usr/share and /var/www.
# The former is used by web applications packaged in Debian,
# the latter may be used for local directories served by the web server. If
# your system is serving content from a sub-directory in /srv you must allow
# access here, or in any related virtual host.
<Directory />
    Options FollowSymLinks
    AllowOverride None
    Require all denied
</Directory>

<Directory /usr/share>
    AllowOverride None
    Require all granted
</Directory>

<Directory /var/www/>
    Options Indexes FollowSymLinks
    AllowOverride All
    Require all granted
</Directory>

#<Directory /srv/>
#   Options Indexes FollowSymLinks
#   AllowOverride None
#   Require all granted
#</Directory>

# AccessFileName: The name of the file to look for in each directory
# for additional configuration directives.  See also the AllowOverride
# directive.
#
AccessFileName .htaccess

#
# The following lines prevent .htaccess and .htpasswd files from being
# viewed by Web clients.
#
<FilesMatch "^\.ht">
    Require all denied
</FilesMatch>


#
# The following directives define some format nicknames for use with
# a CustomLog directive.
#
# These deviate from the Common Log Format definitions in that they use %O
# (the actual bytes sent including headers) instead of %b (the size of the
# requested file), because the latter makes it impossible to detect partial
# requests.
#
# Note that the use of %{X-Forwarded-For}i instead of %h is not recommended.
# Use mod_remoteip instead.
#
LogFormat "%v:%p %h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" vhost_combined
LogFormat "%h %l %u %t \"%r\" %>s %O \"%{Referer}i\" \"%{User-Agent}i\"" combined
LogFormat "%h %l %u %t \"%r\" %>s %O" common
LogFormat "%{Referer}i -> %U" referer
LogFormat "%{User-agent}i" agent

# Include of directories ignores editors' and dpkg's backup files,
# see README.Debian for details.

# Include generic snippets of statements
IncludeOptional conf-enabled/*.conf

# Include the virtual host configurations:
IncludeOptional sites-enabled/*.conf

# vim: syntax=apache ts=4 sw=4 sts=4 sr noet

To install I used composer and then I ran:

sudo bin/magento setup:install --base-url="http://local.magento2.com" --db-host=localhost --db-name=magento2 --db-user=root --db-password=(password) --admin-firstname=Name --admin-lastname=Surname --admin-email=example@email.com --admin-user=admin --admin-password=admin123 --language=en_US --currency=EUR --timezone=UTC --use-rewrites=1 --search-engine=elasticsearch7 --elasticsearch-host=localhost --elasticsearch-port=9200

This is my /etc/hosts/ config:

127.0.0.1   localhost
127.0.1.1   pcportatilrafael
127.0.0.1   local.magento2.com

# The following lines are desirable for IPv6 capable hosts
::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters

These are my /var/www/html/magento contents:

total 1784
drwxrwxrwx  4 www-data www-data   4096 mar  3 22:30 app
-rwxrwxrwx  1 www-data www-data    150 mar  3 22:27 auth.json.sample
drwxrwxrwx  2 www-data www-data   4096 mar  3 22:27 bin
-rwxrwxrwx  1 www-data www-data 766543 mar  3 22:27 CHANGELOG.md
-rwxrwxrwx  1 www-data www-data   2634 jan  7 21:59 composer.json
-rwxrwxrwx  1 www-data www-data 952379 mar  3 22:27 composer.lock
-rwxrwxrwx  1 www-data www-data    650 mar  3 22:27 COPYING.txt
drwxrwxrwx  4 www-data www-data   4096 mar  3 22:27 dev
drwxrwxrwx  4 www-data www-data   4096 mar  3 23:19 generated
-rwxrwxrwx  1 www-data www-data     55 mar  3 22:27 grunt-config.json.sample
-rwxrwxrwx  1 www-data www-data   2994 mar  3 22:27 Gruntfile.js.sample
drwxrwxrwx  4 www-data www-data   4096 mar  3 22:27 lib
-rwxrwxrwx  1 www-data www-data  10376 mar  3 22:27 LICENSE_AFL.txt
-rwxrwxrwx  1 www-data www-data  10364 mar  3 22:27 LICENSE.txt
-rwxrwxrwx  1 www-data www-data   6898 mar  3 22:27 nginx.conf.sample
-rwxrwxrwx  1 www-data www-data   1275 mar  3 22:27 package.json.sample
drwxrwxrwx  2 www-data www-data   4096 mar  3 22:27 phpserver
drwxrwxrwx  6 www-data www-data   4096 mar  3 22:27 pub
-rwxrwxrwx  1 www-data www-data    700 mar  3 22:27 SECURITY.md
drwxrwxrwx  7 www-data www-data   4096 mar  3 22:27 setup
drwxrwxrwx  7 www-data www-data   4096 mar  3 23:19 var
drwxrwxrwx 84 www-data www-data   4096 mar  3 22:27 vendor

When I access local.magento2.com I go to the localhost apache2 page, when I access localhost/magento I get the 404 error... GOing to localhost/phpmyadmin works just fine.

What am I missing here? What am I doing wrong?

1
1

You are missing the apache configuration for your specific magento domain. To create it, you create a file in /etc/apache2/sites-available/ named after your domain followed by .conf. In your case: /etc/apache2/sites-available/local.magento2.com.conf

In that file, you have to set some values:

<VirtualHost *:80>
  ServerAdmin webmaster@localhost
  ServerName local.magento2.com
  DocumentRoot /var/www/html/magento
  <Directory /var/www/html/magento/>
            Options Indexes FollowSymLinks MultiViews
            AllowOverride All
            Require all granted
  </Directory>
  ErrorLog /var/log/apache2/error.log
  LogLevel warn
  CustomLog /var/log/apache2/access.log combined
</VirtualHost>

To activate the config use the command:

sudo a2ensite local.magento2.com.conf

To deactivate the config use:

sudo a2dissite local.magento2.com.conf

I am not sure, if you have to restart apache - but it wouldnt harm anything at this point ;-)

4
  • Thank you so much! Worked like a charm! – Rafael Moreira Mar 4 at 1:09
  • Had to make a small ajustment tho, I changed AllowOverride None to AllowOverride All – Rafael Moreira Mar 4 at 1:22
  • 1
    I will edit my answer, so others can see that, too – Mario Mar 4 at 1:46
  • 1
    Don't know it's a hack or what but worked for me, +1. – Abdul Samad Abbasi Mar 4 at 5:39
2

Actually, we've had a similar problem after upgrade, though there were NO changes in nginx configuration.

Magento removed the index.php file from the main folder as such we're getting 404 on all other pages aside the homepage.

For the time being I've copied the file from pub/ into root folder and it works.

Not a perfect solution, I'll probably have to debug it later why is happening like that.

1

Definetely you're missing the .htaccess

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.