0

I'm using Magento 2.3.3 and I'm not able to install mailchimp. The documentation doesn't seem to be very clear... I'm not entierly sure about my folder path since I cannot find any documentation about it.

I've set up:

/var/www/html/root/app/code/mailchimp/mc-magento2

and

/var/www/html/root/app/code/ebizmarts/mailchimp-lib

With all their specific files downloaded from Magento marketplace.

I've tried the commands:

composer require ebizmarts/mailchimp-lib
composer require mailchimp/mc-magento2:102.3.42

But I always get the error

[InvalidArgumentException]                                                                                                       
  Could not find a matching version of package ebizmarts/mailchimp-lib. Check the package spelling, your version constraint and t  
  hat the package is available in a stability which matches your minimum-stability (alpha).    

So im guessing that It's something about my folder path but I cannot find any information about it. Anyone got any clue? Thanks

What I have checked:

1

I guess you're using wrong installation command.

** You don't need to download and put module files manually to app/code/..... And if you already have module files for mailchimp, remove them first.

Run this command on your magento2 root folder.

composer require mailchimp/mc-magento2
1
  • Thanks! I tried it but I get the error: Your requirements could not be resolved to an installable set of packages. Problem 1 - mailchimp/mc-magento2 102.3.42 requires ebizmarts/mailchimp-lib >=3.0.27 -> no matching package found. – Nicklas Gilbertsson Feb 26 at 7:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.