4

As wrote in the title, after I've upgraded from Magento 2.4.1 to 2.4.2 the message "Only 0 Left" has suddenly appeared in the product page (configurable product).

I checked in Stores->Configuration->Catalog->Inventory->Stock Options->Only X left Threshold and it's set to 0. I tried to set to -1 but nothing's changed.

enter image description here

Any solutions?

3 Answers 3

6

This is a bug affecting configurable products introduced by the new Magento_InventoryConfigurableProductFrontendUi module in Magento 2.4.2. You can read more about the issue here: https://github.com/magento/inventory/issues/3276

As a temporary solution you can disable the module which will remove the message.

bin/magento module:disable Magento_InventoryConfigurableProductFrontendUi
1
  • It seems to solve the issue for now. Thank you.
    – KaMZaTa
    Feb 19, 2021 at 23:09
0

You can also use CSS to temporarily hide the "Only 0 Left"

.availability.only.configurable-variation-qty { display: none !important; }

0

Modify vendor/magento/module-inventory-configurable-product-frontend-ui/view/frontend/web/js/configurable-variation-qty.js or extend this file

change from

if (response.qty !== null && response.qty > 0) {

to

if (response.qty !== null && parseFloat(response.qty) > 0) {

Credit goes to MarekCernak From https://github.com/magento/inventory/issues/3276 thread.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.