0

I am new to Magento and Im trying to setup a Magento developer environment on Windows 10 machine with Docker. I'm using Bitnami Magento images and I managed to start up MariaDB and Elasticsearch docker containers as mentioned in the Bitnami Magento documentation. Once I started Magento container it stops from below log line (docker logs magento)

docker logs magento

docker ps

The magento container is not up as well. I tried several things to find out why this happens but I couldn't find out why. Any idea on this would be really helpful. Thanks.

2

I think your best option is to raise an issue to the Bitnami team and ask for help there.

If you encountered a problem running this container, you can file an issue. For us to provide better support, be sure to include the following information in your issue:

Host OS and version Docker version (docker version) Output of docker info Version of this container The command you used to run the container, and any relevant output you saw (masking any sensitive information)

1
  • Thanks Diana, I'll give it a try. – Darth Shirr Feb 22 at 5:21
0

In case anyone else has this question:

This seems to be normal the first time you fire up the Magento container. If you look at the Magento logs, it keeps going:

docker logs magento_magento_1

Keep running this command every so often, until you see:

/opt/bitnami/apache/bin/httpd -f /opt/bitnami/apache/conf/httpd.conf -D FOREGROUND'

At this point, you can open your browser to http://localhost and you'll see the default Magento storefront.

Open your browser to http://localhost/admin, and you can start configuring your store. Login with user / bitnami1

It will take a few minutes, but eventually you'll see the Dashboard. If not, look at the logs again.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.