0

I just installed a Magento 2.3.6 version. and I tried to run the Command Reindexing but it's not working. I tried with diff commands like cache clear and flush none of the commands are not working through SSH. How can i achieve this thing. Can anyone help me with it please.Please Look at the Screenshot

1 Answer 1

0

I Think the issue is with file permissions run the below commands, it will help you to get out of the issue

find . -type f -exec chmod 644 {} \;
find . -type d -exec chmod 755 {} \;
find var pub/static pub/media  generated/ app/etc -type f -exec chmod g+w {} \;
find var pub/static pub/media generated/ app/etc -type d -exec chmod g+ws {} \;
chmod u+x bin/magento

Then Run

sudo php bin/magento setup:upgrade
php bin/magento setup:di:compile
php bin/magento setup:static-content:deploy -f
php bin/magento cache:clean
6
  • None of the above comments work. It's behaving like same before. When ever i run the command CLI is not responding to it. It's just goes to next line itself. Commented Feb 12, 2021 at 6:56
  • magemonkeys.com/… go through this link Commented Feb 12, 2021 at 8:50
  • Broo, It tried it as mentions in magemonkeys but still im facing the same issue. Can you please help me with it? Commented Feb 12, 2021 at 9:26
  • Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 2621440 bytes) in /home/towercirclestore/public_html/vendor/magento/framework/Setup/Declaration/Schema/Db/MySQL/Definition/Index.php on line 54 It is showing the above error Commented Feb 12, 2021 at 10:12
  • Just add this line before the line where you get error in your php file---> ini_set('memory_limit', '-1'); Commented Feb 12, 2021 at 10:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.