0

I have a Magento site (v2.3.2 CE) hosted on Nexcess. It has several extensions (paid and free) that are very outdated. There are also some custom backend extensions and a custom theme. This site was made 1 year ago by a company that do not exists anymore and even if is in production is a little buggy.

I was called as project manager to fix the bugs and then to customize the shop, but before even do that I'm planning to upgrade to the latest stable (2.4.x) or at least to check its feasibility. My fear is that something will break in the process.

The main idea right now is to use the Nexcess Dev Sites, try to upgrade and check if the update is successful.

Does Nexcess offer support for Magento upgrades (even with paid consultants)?
Does anyone have experience with nexcess consultants?
Do you have any idea of ​​the possible timing or hourly prices?

Thanks
Any advices is welcome.

0

I do not have experience with Nexcess, but our biggest challenge was getting all extensions to be compliant with PHP 7.4. We are running Magento 2.4.1.

0

Please Check all dependencies first before upgrading!

  • Check each Plugin for compability with Magento 2.4.1.

  • When you plan to upgrade make sure to backup your database. Because upgrading to Magento2.4.x requires at least MySQL 5.7 or m MySQL 8 at least. Please check the compability when u use a different database like MariaDB for example.

  • ElasticSearch should be also installed on your Server. So make sure it is installed.

4
  • 1
    2.4 supports MySQL 8 - you do not require MySQL 8 to upgrade from 2.3 to 2.4.
    – paj
    Jan 25 '21 at 7:02
  • "Magento 2.4 requires a clean installation of MySQL 8.0. Follow the links below for instructions on installing MySQL on your machine. " devdocs.magento.com/guides/v2.4/install-gde/prereq/mysql.html Jan 25 '21 at 9:48
  • The question is about upgrading, not installing.
    – paj
    Jan 25 '21 at 16:52
  • Ok I thought when you upgrade you have also to upgrade your database to the mentioned version. Anyway, when you upgrade with a database lower than MySQL 5.7 then it is not working. But I think it is recommend to upgrade to MySQL8 to take advantage of its improved performance, security, and reliability. Also Magento 2.4.x is not tested with MySQL 5.7. devdocs.magento.com/guides/v2.4/release-notes/… Jan 25 '21 at 20:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.