1

I'm working with a new installation of 2.3.5.

I am unable to import a multi-select product attribute.

My attribute I'm trying to import is "Year" for auto parts.

I have tried importing with the column header "year", which is the attribute code. I have also tried importing with the column header "additional_attributes" with value "Year=1967|1968". Neither of these work.

When I manually set the "year" attribute on a product and export that product, it is exported via "additional_attributes" with value "Year=1967|1968".

I've tried importing exactly what is exported, but that doesn't work either. It doesn't give me any errors when importing, it just doesn't change any value on the product.

I've tried using a semicolon, a comma, etc. as field separator. I have "Fields enclosure" unchecked as well.

All attribute values I'm importing already exist within the "Year" attribute.

Any help would be greatly appreciated.

Thanks.

0

Update: Problem fixed. I am just updating this in case anyone searching has this problem.

My problem was that the admin code on my attribute had a capital letter in it. It was "Year". I deleted that attribute and added a new one called "year" and I am able to import with no issues.

sku,additional_attributes
1234,year=1967|1968

The above CSV imports properly. Pipe "|" is required rather than a comma and it is required to change "Multiple value separator" in Magento admin to pipe | as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.