0

Check https://getcomposer.org/doc/articles/troubleshooting.md#memory-limit-errors for more info on how to handle out of memory errors.

{"messages":{"error":[{"code":500,"message":"Fatal Error: 'Allowed memory size of 134217728 bytes exhausted (tried to allocate 4096 bytes)' in '/home/a1pro/public_html/magento/vendor/magento/framework/ObjectManager/Factory/AbstractFactory.php' on line 121"

when i checked during command then it shows 128M only. but i have changed with php_value memory_limit 2048M .

0

There are two other Magento 2 files that might override your default php.ini settings

  1. magentoroot/.user.ini
  2. magentoroot/.htaccess

Check these files for existing php_value memory_limit settings and modify as needed.

2
  • I have changed in these files but still if i checked via command it will show 128M. – Php eweb Jan 18 at 11:35
  • from the command line do php -i (or use phpinfo() via a web page) and check the configured location of php.ini - make sure you are editing the correct php,ini file! – paj Jan 18 at 14:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.