I have multiple address in my account. In the checkout, default shipping address is selected on the page load but the default billing address is not selected, instead I can see all the available addresses in the drop down.

Is there any code I have to make change to make default billing address to be auto selected in the checkout?

Thanks in Advance!!

  • I think you should try again with incognito mode. By default, Magento will choose your default billing address, but once you change it in dropdown, on the next reloading, it will change to your previous selected value. – Jimmy Mar 16 at 3:58
  • @Jimmy, yes i tried in incognito mode. for me its not working. my version is 2.3.5 – jafar pinjar Mar 16 at 5:33
  • I don't have 2.3 here but in 2.4 it's working as expected. The billing select element will be set to default billing after you uncheck the option my billing and shipping are the same – Jimmy Mar 16 at 7:54
  • In case you want to debug, check these 2 files, it's where the logic runs Magento_Checkout/view/frontend/web/js/view/billing-address.js and Magento_Checkout/view/frontend/web/js/view/billing-address/list.js – Jimmy Mar 16 at 7:57
  • @Jimmy, These two files are fresh file not overwritten or modified. default billing address is set properly in DB but not auto selected in dropdown, where is the logic written for for pre selecting default address – jafar pinjar Mar 16 at 11:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.