0

I have two identical configurable products ( name and photoes are little bit different). from admin everything is the same but one configurable product is visible other is not. Skus are not identical so that is not a problem.

3
  • Did you run reindex, check URLs and their inventory/stock?
    – Wasim
    Jan 12 at 18:08
  • Yes, reindex didn't fix the problem. Jan 12 at 20:04
  • check URLs and their inventory/stock?
    – Wasim
    Jan 13 at 4:44
0

Hey Giga,

I do read your problem carefully, and i have few solution for you, may it will help you out in this problem.

First Solution: As in magento, there is an option for duplicate product, you using this you can create the duplicate product and make the changes that you want for you, it will work as i do test it on my local.

Second Solution: If you did create the same config product manullay, then make sure you have change the URL name & Seo of that config product, becuase as per your given data, you said that you did only change few thing, like SKU, images, name. Its just hit the same URL, again and rewrite that, thats why the problem is occur.

Thanks

0
  1. Checked if all of these products are available and have correct data on frontend by using direct link, e.g ..... . All good at this step.
  2. Checked if these products are missing on category page. They were missing.
  3. Checked indexing statuses. Catalog Search required reindexation.
  4. Checked cron jobs, if they are running in cron_schedule table.
  5. In cron_schedule table found the following error -> {"error":{"root_cause":[{"type":"cluster_block_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"}],"type":"cluster_block_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"},"status":403}
  6. It is elasticsearch error, elasticsea1. Checked if all of these products are available and have correct data on frontend by using direct link, e.g ..... . All good at this step.
  7. Checked if these products are missing on category page. They were missing.
  8. Checked indexing statuses. Catalog Search required reindexation.
  9. Checked cron jobs, if they are running in cron_schedule table.
  10. In cron_schedule table found the following error -> {"error":{"root_cause":[{"type":"cluster_block_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"}],"type":"cluster_block_exception","reason":"blocked by: [FORBIDDEN/12/index read-only / allow delete (api)];"},"status":403}
  11. It is elasticsearch error, elasticsearch went into READ-ONLY mode. So not possible to write any data into elastic. This usually happens when left less than 5% of storage.
  12. Went to the server, validated search indexer by running reindexxation: sudo -u www-data bin/magento indexer:reindex catalogsearch_fulltext . Got the same error
  13. Checked storage empty space, using df -h . All good, main storage has 49% free space.
  14. Went to google, found the following Elasticsearch query to disable read-only mode manually -> curl -XPUT -H "Content-Type: application/json" http://{ELASTIC_HOST}:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}' In our case -> curl -XPUT -H "Content-Type: application/json" http://172.31.16.24:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'
  15. Run this curl request, received successful response.
  16. Reindex catalogsearch_fulltext indexer
  17. Validated these productsrch went into READ-ONLY mode. So not possible to write any data into elastic. This usually happens when left less than 5% of storage.
  18. Went to the server, validated search indexer by running reindexxation: sudo -u www-data bin/magento indexer:reindex catalogsearch_fulltext . Got the same error
  19. Checked storage empty space, using df -h . All good, main storage has 49% free space.
  20. Went to google, found the following Elasticsearch query to disable read-only mode manually -> curl -XPUT -H "Content-Type: application/json" http://{ELASTIC_HOST}:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}' In our case -> curl -XPUT -H "Content-Type: application/json" http://172.31.16.24:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'
  21. Run this curl request, received successful response.
  22. Reindex catalogsearch_fulltext indexer
  23. Validated these products
0
  1. Check Product stock(In stock or out of stock)
  2. or Check the Category of Product
  3. or do reindex
1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.