0

I use elasticsuite: https://github.com/Smile-SA/elasticsuite

Everytime when I create new category or assign products to categories items in all categories in frontend will disappear after a while.

When I try run reindex:

elasticsuite_categories_fulltext | ElasticSuite Category Indexing 

I get:

no alive nodes found in your cluster magento 2

I need:

systemctl restart elasticsearch.service

and

bin/magento indexer:reindex  elasticsuite_categories_fulltext

and then I see products in frontend. Its crazy and take a time.

I think I have some wrong setting.


In backend configuration module I see indices mapping: enter image description here

  1. Should I add any more indexes here for mapping?
  2. Second thing: I see in base configuration mapping incides:
  • catalog_category
  • catalog_product

But my index have name:

  • catalog_category_product
  • catalog_product_category

should i change these settings? Should I map any additional indexes here?

Here is list all index:

catalogrule_product              | Catalog Product Rule            | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:11 |
| catalogrule_rule                 | Catalog Rule Product            | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:11 |
| catalogsearch_fulltext           | Catalog Search                  | Reindex required | Schedule  | suspended (0 in backlog) | 2021-01-11 12:39:35 |
| catalog_category_product         | Category Products               | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:10 |
| customer_grid                    | Customer Grid                   | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:10 |
| design_config_grid               | Design Config Grid              | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:10 |
| elasticsuite_categories_fulltext | ElasticSuite Category Indexing  | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:11 |
| elasticsuite_thesaurus           | ElasticSuite Thesaurus Indexing | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:11 |
| inventory                        | Inventory                       | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:11 |
| catalog_product_category         | Product Categories              | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:10 |
| catalog_product_attribute        | Product EAV                     | Ready            | Schedule  | idle (0 in backlog)      | 2021-01-11 12:51:11 |
| catalog_product_price            | Product Price                   | Processing       | Schedule  | suspended (0 in backlog) | 2021-01-11 12:50:08 |
| cataloginventory_stock 
1
  • Check your elasticsearch server logs for errors and make sure you are assigning enough heap size memory from java.options in the server config.
    – paj
    Jan 11, 2021 at 17:05

1 Answer 1

0

You can confirm whether Elasticsearch is installed or not.
curl localhost:9200

Before you reindex you can check Elasticsearch configuration from Backend. In admin panel you can test the elastic search connection. Please make sure the host and server port are matched with your configuration. Goto Admin -> Store -> configuration -> catalog -> catalog

enter image description here

After this, clear cache and reindex. It will solve your issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.