0

I am experiencing a problem in my magento 2 store. I cannot set the line quantity in Settings> Client Configuration> Name and Address Options> Number of Lines in Address I can put any value 1, 2,3 or 4 Magento always returns only two lines as shown below. This error occurs in all places where the customer's address is placed, either in the admin, in / customer or at the checkout All the basic procedures for cleaning caches, compilation and deploys were done, I even rebooted the server but nothing worked. Environment: PHP 7.3 Magento 2.3.6 Opcache Redis MYSQL

Magento is in developer mode, none exception for this error.

I did a search for street in my database and got these results in the table eav_attribute.

I just recently migrate the data from my magento 1 store and I believe something is corrupted in my database.

Magento Error

eav_attribute

eav_attribute

0

Not sure whether you're on Enterprise or Open-Source Magento you're on. ( That being said - I assume the steps below apply to both )

Note: The instructions below were executed and validated on a Magento (Enterprise) 2.3.5-p2 instance.

.

.

.

To update the # of Address lines displayed on the website:

  • Login to Magento Admin UIX -> Stores -> Attributes : Customer Address -> Click on the Row corresponding to "Attribute => Street" enter image description here

  • Update the value of the attribute "Lines Count" to the desired value -> Click on the "Save Attribute" button enter image description here

  • Re-run Magento Indexers

    bin/magento index:reindex

  • Flush Magento Caches

    bin/magento cache:flush

1
  • Hello Sharath Kumar, thanks for your awnser, unfortunately my version is Open-Source and does not have these attribute options for customer, would you know to tell me which tables are affected with this option number that is placed in line count? – Jadiel Leyendecker Jan 7 at 23:41
0

after scanning my database searching a corrupt or bad configuration, i found the problem, in my case CUSTOMER_EAV_ATTRIBUTE_WEBSITE, IN THE MULTI-LINE_COUNT COLUMN there was set with number 2, consequently showing only two lines in the address, so i set the column for 4, and it makes show 4 lines address in front-end store.

But still stay the Big question;

WHY this value do not change in mydatabase, even though it changes in the store admin?

My store is developer_mode, and there is no error in debugs logs.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.