0

Hello I want to create multi language site in magento2. I have follow particular magento2 tutorial.link that I have used. After I have follow command 1.php bin/magento indexer:reindex 2.php bin/magento cache:flush 3.php bin/magento setup:upgrade 4.php bin/magento cache:flush 5.php bin/magento setup:di:compile 6.php bin/magento cache:disable

to solve this issue I have given screenshot below for frontend and backend front end frontenad back end backend

8
  • did you run content-deploy command and given proper permissions to all magento folders? Jan 7, 2021 at 6:33
  • what is your all store language and also admin user language ?? Jan 7, 2021 at 6:36
  • i have selected french language and create store of french.
    – jaydipsinh
    Jan 7, 2021 at 6:38
  • i don't know about permission but i have run php bin/magento setup:static-content:deploy -f
    – jaydipsinh
    Jan 7, 2021 at 6:39
  • bsscommerce.com/confluence/… Jan 7, 2021 at 6:45

1 Answer 1

0

Run the below commnds,

php bin/magento s:up
php bin/magento s:s:d -f en_US fr_FR
php bin/magento c:f
19
  • i.imgur.com/qeOHgCk.png after hit below command it given this error
    – jaydipsinh
    Jan 7, 2021 at 7:16
  • it's permission error , give the 777 permission of your magento root folder Jan 7, 2021 at 7:19
  • mean i have magento2 folder so i have to set permission sudo chmod 777 magento2 it it right
    – jaydipsinh
    Jan 7, 2021 at 7:21
  • sudo chmod -R 777 magento2/ Jan 7, 2021 at 7:23
  • is it good option give hole project to 777 permission?
    – jaydipsinh
    Jan 7, 2021 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.