2

enter image description here

Hi, can anyone help to identify how to fix this? I am installing from a Magento 2.4 Script onto ubuntu 20.04.

Thanks

1
  • 1
    Can you provide us the entire command which you executed? Edit your question, thanks.
    – Ferrmolina
    Jan 6, 2021 at 14:53

2 Answers 2

0

Its possible you forgot some flag.

Try with this command:

bin/magento setup:install --backend-frontname="admin" \
--db-host="localhost" \
--db-name="database_name" \
--db-user="username" \
--db-password="password" \
--language="en_US" \
--currency="GBP" \
--timezone="Europe/London" \
--use-rewrites=1 \
--use-secure=0 \
--base-url="http://www.magentourlbase.com" \
--base-url-secure="https://www.magentourlbase.com" \
--admin-user=adminuser \
--admin-password=123123q \
[email protected] \
--admin-firstname=admin \
--admin-lastname=user \
--cleanup-database
3
  • I tried this and this is what's coming up - SQLSTATE[HY000] [1045] Access denied for user 'simon'@'localhost' (using password: YES) In InstallCommand.php line 274: Parameter validation failed Jan 6, 2021 at 20:10
  • 1
    Got it installed, thank you!! It seems to be taking a long time to get the authentication email through is this normal? Jan 6, 2021 at 21:29
  • Be sure of the email service is working. If you are in a local environment and want to log in into the admin area, i recommend you to disable the Magento_TwoFactorAuth module, running: bin/magento module:disable Magento_TwoFactorAuth && bin/magento se:up in order to sign in without 2f validation.
    – Ferrmolina
    Jan 7, 2021 at 0:29
0

In my case it was because I used a password which is not supported by the setup install command.

My password was like "company!!", I had to remove the !!. I replaced it with company11 and now it works.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.