0

Good morning. I'm still pretty new to Magento since I started using it not too long ago. My company had to change webhosts because our previous host didn't have Cronjobs. Now after moving all the files, a lot of sites won't open. This is the site. The backend also changed from url/admin to url/index.php/admin for some reason.

Can anyone please help me with this? Thanks in advance.

edit04: When I first installed Magento onto the server, I had to clear all .htaccess files because they had something in them that was not compatible with our host. But since then it has been working fine. Whatever fine is in this case. At least the backend doesn't give me any trouble.

edit01: That's how my .htaccess looks right now:

############################################
## enable rewrites

    Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################

edit02: If I add the .htaccess file into main directory, the site stops working. (Unless it changes back to url/admin) In the config/web the "use server rewrites" option is on

edit03: So it does not just change back to url/admin. This is what happens everytime I add the .htaccess file into "magento/"

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, admin and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
  • it seems your .htaccess has some issue, please use original .htaccess from magento package and then test again – sIiiS Aug 20 '14 at 7:19
  • overwrote the .htaccess file in the root directory with the original-magento-install one. After that I cannot even go into backend. If I delete or empty the file however it works again. I quote from the world4you FAQ: "Entries like Options, php_flag, php_value etc. are not allowed and have to be deleted." – theHubi Aug 20 '14 at 7:26
  • so, uncomment Options +FollowSymLinks from .htaccess and test – sIiiS Aug 20 '14 at 7:31
  • I had to delete a lot of php_flags. Now it's working again. "## enable rewrites | Options +FollowSymLinks | RewriteEngine on | I removed the Options-line – theHubi Aug 20 '14 at 7:35
  • only uncomment Options +FollowSymLinks and test, do not delete anything else – sIiiS Aug 20 '14 at 7:44
0

Make sure you have mod_rewrite enabled on your new server.
Let's take the registration page for example:

http://www.wein-partner.at/shop/customer/account/create/ does not work, but http://www.wein-partner.at/shop/index.php/customer/account/create/ does.

So I'm 99% sure that mod_rewrite is the issue here.

  • 1
    I agree with what @Marius is saying. Make sure your AllowOverride directive is set correctly i.e ALL httpd.apache.org/docs/2.2/mod/core.html#allowoverride – Danny Dev Nz Aug 20 '14 at 6:58
  • so basically I have to add into my .htaccess: "AllowOverride All"? Is that correct? – theHubi Aug 20 '14 at 7:03
  • @theHubi. Not only that. You need to make sure that the mod_rewrite apache (if you are using apache) module is enabled. Here is how you can check if it's enabled: stackoverflow.com/questions/9021425/… and here are some details on what you need to do: stackoverflow.com/questions/869092/… – Marius Aug 20 '14 at 7:04
  • well if I log into our host I get: "MySQL Databases" I can log into the database used for Magento and have phpMyAdmin from there on – theHubi Aug 20 '14 at 7:09
  • if it helps, the new host is world4you.com – theHubi Aug 20 '14 at 7:11
-2

Ok so everything works again! Thanks everyone!

I owe you one.

summary:

editing the .htaccess file and enabling RewriteEngine + checking the config/web for rewrite was successful.

/closed/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.