1

I am running Magento 2.3.3 and I an issue with product catalog images not showing both on frontend and adminhtml.

I have seen that it is a common problem, but I tried all recommended solutions, but nothing worked.

This is what I have tried so far:

chmod -R 0777 var/ pub/
bin/magento deploy:mode:set developer
bin/magento setup:static-content:deploy -f en_US he_IL --language en_US --language he_IL
bin/magento cache:flush
bin/magento cache:clean
bin/magento indexer:reindex

I also tried to rename pub/media/catalog/product/cache to _cache.

When I tried bin/magento catalog:image:resize I am getting this error on all images:

Cannot resize image "/home/mysite/public_html/releases/20201220114403/pub/media/catalog/product/5/1/5113-g.jpg" - original image not found

I think that this is related to this bug in core magento, that apparently was fixed in 2.3.4: magento catalog:images:resize now Database Media Storage mode aware (Again!)

I am pretty sure that images exists on disk and database (how can I test this?), just that magento is stuck on old cache and is not refreshing.

Any suggestions to solve this issue?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.