1

I am facing below error in exception.log file. How can i resolve this error?

{"error":{"root_cause":[{"type":"illegal_argument_exception","reason":"no mapping found for field [amxnotif_hide_alert_value]"}],"type":"search_phase_execution_exception","reason":"all shards failed","phase":"query","grouped":true,"failed_shards":[{"shard":0,"index":"magento2_product_1_v226","node":"YsQHRziLSUeMo8kQPmEqbw","reason":{"type":"illegal_argument_exception","reason":"no mapping found for field [hide_value]"}}],"caused_by":{"type":"illegal_argument_exception","reason":"no mapping found for field [amxnotif_hide_alert_value]","caused_by":{"type":"illegal_argument_exception","reason":"no mapping found for field [hide_value]"}}},"status":400} {"exception":"[object] (Elasticsearch\\Common\\Exceptions\\BadRequest400Exception(code: 400): {\"error\":{\"root_cause\":[{\"type\":\"illegal_argument_exception\",\"reason\":\"no mapping found for field [hide_value]\"}],\"type\":\"search_phase_execution_exception\",\"reason\":\"all shards failed\",\"phase\":\"query\",\"grouped\":true,\"failed_shards\":[{\"shard\":0,\"index\":\"magento2_product_1_v226\",\"node\":\"YsQHRziLSUeMo8kQPmEqbw\",\"reason\":{\"type\":\"illegal_argument_exception\",\"reason\":\"no mapping found for field [hide_value]\"}}],\"caused_by\":{\"type\":\"illegal_argument_exception\",\"reason\":\"no mapping found for field [hide__value]\",\"caused_by\":{\"type\":\"illegal_argument_exception\",\"reason\":\"no mapping found for field [amxnotif_hide_alert_value]\"}}},\"status\":400} at /vendor/elasticsearch/elasticsearch/src/Elasticsearch/Connections/Connection.php:632)"} []

and

Cannot search on field [upc_code] since it is not indexed
3
  • Hello there, I have not the exact solution but I work around to fix this issue. Please check the eav attribute upc_code , amxnotif_hide_alert_value is searchable or not. I'm pretty sure these attributes are set to be searchable so please select no to is_searchable for these attribute and then run reindex. Let me know your feedback Thanks
    – Shankar
    Commented Dec 2, 2020 at 12:09
  • 1
    @Shankar, Thanks for your reply. Let me apply your fix. Commented Dec 2, 2020 at 13:58
  • @sanjay do reindex and then check.
    – ZealousWeb
    Commented Feb 9, 2021 at 12:34

1 Answer 1

0

I executed this command in the terminal

bin/magento indexer:reindex catalogsearch_fulltext

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.