1

I recently installed Magezon Pagebuilder plugin. It works perfect and everything, however when I add Sliders or Carousel I get this 2 errors:

require.js:1895 GET http://dev.emall.com.mx/pub/static/version1606325200/adminhtml/Transom/ChangeAdminLogo/en_US/jquery-ui-modules/widget.js net::ERR_ABORTED 404 (Not Found)


Uncaught Error: Script error for: jquery-ui-modules/widget
http://requirejs.org/docs/errors.html#scripterror
    at makeError (require.js:166)
    at HTMLScriptElement.onScriptError (require.js:1681)

I have tried this solutions:

php bin/magento setup:static-content:deploy 
php bin/magento setup:di:compile
php bin/magento setup:upgrade

Delete var/cache and var/view_preprocessed.

clean cache

I checked my .htaccess and seems to be in order, in pub/static and pub/media.

I have used all solutions I know, what could it be?

Thanks!

4
  • this seems like a third party issue. did you check its compatibility with the Magento version you are using?
    – fmsthird
    Commented Nov 26, 2020 at 5:14
  • I see this in the module: Compatibily Community Edition: 2.0.x, 2.1.x, 2.2.x, 2.3.x, 2.4.x Commented Nov 26, 2020 at 15:17
  • remove var/cache and pub/static contents except .htaccess file then try to reinstall the plugin. if still won't work. try to install the plugin with fresh installation of Magento. It might be that proper file permissions are not set.
    – fmsthird
    Commented Nov 26, 2020 at 22:09
  • no luck my friend, any other suggestions? Commented Nov 27, 2020 at 17:05

2 Answers 2

1

In Magento 2.2.7 i have set:

define([
    'jquery',
    'jquery/ui',
    'Magezon_Core/js/owl.carousel.min'
]
1
  • Thank you! I'm running 2.2.9 and had 'jquery-ui-modules/widget' which I've replaced with 'jquery/ui'. Voila, it works!
    – nordashi
    Commented Feb 27 at 16:55
0

I have discovered what was causing the problem in case you have the same error with this Magezon PageBuilder module.

in app/code/Magezon/PageBuilder/view/base/web/js/slider.js the jquery ui-modules are defined like this:

define([
    'jquery',
    'jquery-ui-modules/widget',
    'Magezon_Core/js/owl.carousel.min'
]

I don't know if it's my Magento 2.3.1 version, but I changed it for this , and it worked.

define([
    'jquery',
    'jquery/ui-modules/widget',
    'Magezon_Core/js/owl.carousel.min'
]

Just change jquery-ui-modules for jquery/ui-modules. The errors will disappear and sliders will work fine.

Greetings!

1
  • in my case thi define([ 'jquery', 'jquery-ui-modules/widget', this declaration is every where in magento 2 Commented Jul 2, 2021 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.