2
The "magento/magento-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.0") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.
The "magento/inventory-composer-installer" plugin was skipped because it requires a Plugin API version ("^1.1") that does not match your Composer installation ("2.0.0"). You may need to run composer update with the "--no-plugins" option.

I am facing the above issue, I need to downgrade Magento2 composer version. How can i downgrade composer version 2 to 1.

1 Answer 1

1

You can simply run composer self-update version_number
Example:composer self-update 1.10.0

You can check composer available versions here https://getcomposer.org/download/

3
  • composer downgrade successfully, but the issue still remains.
    – Yogesh
    Nov 25, 2020 at 6:42
  • 1
    @Yogesh did you try composer update --ignore-platform-reqs ?
    – fmsthird
    Nov 25, 2020 at 9:31
  • its something pipeline issue in our bitbucket.
    – Yogesh
    Nov 25, 2020 at 14:03

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.