0

I just upgraded from 2.3.4 to 2.4.1 , before there is no issue when load content using iframe, but now there is always an error message:

Refused to display 'http://test.m2.local/test/index/test/' in a frame because it set 'X-Frame-Options' to 'deny'.

Refused to display '' in a frame because it set multiple 'X-Frame-Options' headers with conflicting values ('DENY, SAMEORIGIN'). Falling back to 'deny'.

the app/etc/env.php already included SAMEORDIGIN configuration

'x-frame-options' => 'SAMEORIGIN',

before i upgrade to 2.4.1, i duplicated the 2.3.4 instance and hosted in different sub domain in the same server, but it does not get any error

I already set in ssl configuration like this:

Header always set X-Frame-Options SAMEORIGIN

then i got this kinda same error result:

Refused to display '' in a frame because it set multiple 'X-Frame-Options' headers with conflicting values ('DENY, SAMEORIGIN, SAMEORIGIN'). Falling back to 'deny'.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.