0

I'm using Magento 2.3.2 with 3 store views for languages and Porto Smartwave Theme.

All Products are created as Simple Product for "All Store Views", the Thumbnails have roles assigned, but some products show the default Magento Thumbnail image in another Store View but show the actual selected Thumbnail in the other.

It seems like a random behavior, i couldn't find any pattern behind it and there is no console error or error in system, exception or debug.log

I have checked the $productImageUrl variable in /Magento_Catalog/templates/product/list.phtml and it is the path to the defualt image in one store view and the actual correct image path in the other store view.

I've tried:

  • bin/magento c:f
  • bin/magento setup:static-content:deploy
  • bin/magento catalog:images:resize
  • and also deleted the cached images in /pub/media/catalog/product/cache but with no result.
New contributor
Daniel_K is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
  • Not relative to the question, but if you may, can you send me the book: 'No-Frills-Magento-2-Layout' by Alan Storm ? I have searched for it online but unfortunately I didnt find it. – Alea Nov 19 at 15:08

Your Answer

Daniel_K is a new contributor. Be nice, and check out our Code of Conduct.

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.