0

I am trying to install https://www.appjetty.com/magento2-magemob-inventory.htm, After installed the module during di:compile command i am getting the following error,

Class Magento\Inventory\Model\Source does not exist Class Biztech\Inventorysystementerprise\Controller\Mobileassistantpro\Product\addNewProduct\Interceptor generation error: The requested class did not generate prop erly, because the 'generated' directory permission is read-only. If --- after running the 'bin/magento setup:di:compile' CLI command when the 'generated' directory permission is set to write --- the requested class did not generate properly, then you must add the generated class object to the signature of the related constru ct method, only. Nov 9, 2020

I am installed my Magento using GitHub installation, Inventory files missing app/code/magento path, how to install manually. Source: https://devdocs.magento.com/extensions/inventory-management/

2
  • did you try chmod 777 command on generated folder? Commented Nov 10, 2020 at 11:27
  • Yes, but same error
    – zus
    Commented Nov 10, 2020 at 11:31

1 Answer 1

1

You can get the missing Magento Inventory (a.k.a MSI) packages from: https://github.com/magento/inventory

For Magento 2.3.x you need to get the latest 1.1.x release.

copy all module folders to app/code/Magento and run:

php bin/magento s:up
6
  • For my clarity, all the files move to app/code/magento, right?
    – zus
    Commented Nov 10, 2020 at 12:30
  • Yes, i've updated my answer; Please upvote if it helps! Commented Nov 10, 2020 at 12:33
  • Column definition "order_id" and reference column definition "entity_id" are different in tables "inventory_pickup_location_order" and "sales_order" Column definition "order_id" and reference column definition "entity_id" are different in tables "inventory_order_notification" and "sales_order" Column definition "address_id" and reference column definition "address_id" are different in tables "inventory_pickup_location_quote_address" and "quote_address"
    – zus
    Commented Nov 10, 2020 at 12:39
  • what is the error mean?
    – zus
    Commented Nov 10, 2020 at 12:39
  • 1
    Sorry, according to devdocs.magento.com/guides/v2.4/inventory/release-notes.html you should use version 1.1.6 for Magento 2.3: github.com/magento/inventory/releases/tag/1.1.6 Commented Nov 10, 2020 at 13:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.