0

I'm trying to upgrade Magento 2 with the latest release Magento 2.3.6 and getting an error while running the upgrade command.

Unable to apply data patch Magento\Elasticsearch\Setup\Patch\Data\InvalidateIndex for module Magento_Elasticsearch. Original exception message: Notice: Undefined index: in /var/www/html/vendor/magento/framework/App/Route/Config.php on line 93

Currently we are using Magento 2.3.5-p2 version and algolia for search. Previously we used Wyomind Elastic search and now the modules are disabled.

Do anyone have an idea about the issue? Please help me to resolve the same.

0

Try to rename vendor folder to vendor-old and run composer update if it's correctly configured.

When renamed vendor folder follow steps below:

  1. Make a backup copy of composer.json in your Magento installation directory
  2. Open composer.json in a text editor.
  3. Locate the following line:

"require": { "magento/product-community-edition": "" },

  1. Replace with the version to which you want to upgrade, where is the product version to use, in your case 2.3.6.

  2. Save your changes and run the following command: composer update

https://devdocs.magento.com/guides/v2.4/install-gde/install/cli/dev_reinstall.html

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.