I recently needed to clear my test data, so I ran through the steps in this post: Clearing Magento after testing

Ever since then any products I add don't show up in categories (I've confirmed they're assigned to a category) or in search results (autocomplete looks like there should be results). The thing that makes it weird is that if I pull the slug for a product from the admin I can navigate directly to the product page. So the products are visible on the front end, they're just not showing up, almost like there's a broken association somewhere.

I've gone through re-index, I've cleared cache, I've tried manually adding a new product with various inventory settings. Nothing seems to get a product to show up in category nav or search results.

I'll provide anything I can, I'm just not sure what is relevant here.

2 Answers 2


You might have a indexing issue.

Kindly run following command and then check again.

php bin/magento indexer:reset
php bin/magento indexer:reindex 
php bin/magento c:f

If this helps you then hit like and accept as answer.

Meanwhile, enjoy your coding !!! :)

Thank you,
Hiren Patel

  • That looks like commands for Magento 2, I'll look to see if there's something similar for Magento 1.9
    – G. Reed
    Oct 26, 2020 at 18:51
  • (was 3 minutes too late for an edit) Ran through re-indexing again, no change. Cleared all caches again, no change.
    – G. Reed
    Oct 26, 2020 at 19:01

In my experience this is an issue with the Category Products index so make sure you are indexing that specific one.

Another thing can be the Websites configuration of each of your products. If you edit a product there is a Websites tab. Ensure that your products have a website selected. Also check the catalog_product_website table to check the current associations. You might have to reassign everything if this information is missing and the reindex everything.

Another, last resort, thing you can try is modifying the source code for app/code/core/Mage/CatalogSearch/Model/Layer.php temporarily more specifically the prepareProductCollection method.

You should comment the following lines


If the products appear the for sure you have an indexing problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.