0

I have created a virtual host for my Magento site in my local magento.site.local (my virtual host)

and I have also created a self-signed SSL certificate using OpenSSL and I have imported the certificate in chrome also.

but still, I am getting the URL as unsecure but it is showing https://magento.site.local and in this (https is in red and striked with a line horizontally) and shows unsecured.

in the console i am getting an error like this

DOMException: Failed to register a ServiceWorker for scope ('https://magento.site.local') with the script ('https://magento.site.local/firebase-messaging-sw.js'): An SSL certificate error occurred when fetching the script.

0
1

In the latest versions of Chrome, you can enable SW like this by enabling this flag in chrome chrome://flags/#unsafely-treat-insecure-origin-as-secure

to test this in firefox you can use devtools.serviceWorkers.testing.enabled setting.

1
  • no still not working for chrome – sandesh s Oct 21 '20 at 6:26

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.