0

I am receiving this error. I tried with the followings:

  1. Changing the file permission in generated folder
  2. Tried removing cache and page_cache in var folder
  3. Then tried removing generated folder as well

Then once I run the php -dmemory_limit=10G bin/magento setup:di:compile I am receiving this error code. How can I fix this please?

setup:di:compile code

2
  • I think your generated folder has wrong permission, please check your PHP and apache/nginx user has permission to write in generated folder – Murtuza Zabuawala Oct 27 '20 at 8:59
  • @MurtuzaZabuawala I changed the permission also. But same error is occurring when compile it again. This works fine before. Suddenly being into this error. – WP Learner Oct 27 '20 at 9:01
0

Try this command in your magento directory and check if it works chmod -R 777 var/ generated/ pub/static or just chmod -R 777 var/ generated/ . You can use different locations to grant permissions with this command.

1
  • I did this before. But same issue is generating again and again. – WP Learner Oct 27 '20 at 10:24
0

there is quick win for you with this issue. It is likely that you do not need to have Dotmailer module enabled in your site.

So, unless that is the case for you, you may approach this in 2 phases:

  1. disable the modules:

    php bin/magento mod:dis Dotdigitalgroup_Email Dotdigitalgroup_Chat

  2. if it fixes the issue and if you genuinely don't need the modules (meaning, you don't have an active account with them), then you may remove the dotmailer related entries from your composer.json file and then run composer install. Before doing this, it is important to have a backup of database and site's codebase.

Finally, if you'd want to understand the issue. The place to start is to find in your codebase app/code folder and vendor folder places that use the class XSLTProcessor. Since this word is quite unique, you are likely to find a plugin somewhere in your codebase that needs tuning.

1
  • I'll check this and get back to you. – WP Learner Oct 31 '20 at 16:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.