7

I decided to perform a SYSTEM Backup via the admin of my website at 4:13am, even though I'm not so techy with Magento. It kept showing 'Please Wait' all the while. I went to bed, woke after 6hours and it was still the same. I left it for a long while till around 11:30pm and it was still showing 'Please Wait'. While it was performing the backup, I couldn't access both the frontend and backend of the website.

As I wasn't sure of what to do to bring the website back alive, I stopped the Backup at about 11:40pm by typing a different web address into the URL. Having done that, nothing seems to have changed and I still can't access both the backend & frontend.

Please I need some advice on what to do. Please do let me know if you require more clarification.

  • Maintenance.flag doesn't seem to be in the Magento installation folder. I have also cleared the cache by deleting the var/cache and var/session but still the same. It gives HTTP 500 error message: Most likely causes: •The website is under maintenance. •The website has a programming error. – Joe Dara Apr 25 '13 at 1:45
  • I have managed to resolved it by changing the permission for index.php fromm 666 to 644. – Joe Dara Apr 25 '13 at 4:22
2

This is kind of a shot in the dark, but is there a file called maintenance.flag in the root of your Magento installation folder? If so, delete it and everything should work.

  • I have read somewhere that I should delete the maintenance.flag but it doesn't appear in within the installation folder. – Joe Dara Apr 25 '13 at 1:42
  • I have also cleared the cache by deleting the var/cache and var/session but still the same. It gives HTTP 500 error message: Most likely causes: •The website is under maintenance. •The website has a programming error – Joe Dara Apr 25 '13 at 1:44
  • I would check the logs in /var/log/ and see if you can find a more detailed error message and a stack trace there. – cameronhimself Apr 25 '13 at 4:06
2

Based on the comments above, the original poster solved this problem by

changing the permission for index.php fromm 666 to 644

This is likely a security precaution of their shared web host — many shared web hosts systems consider 666 an invalid permission and have special monitors in place to prevent users from serving such files.

  • SuExec, SuPHP and cPanel WHM all expect files (especially top level, directly executed PHP files) to not be world writable. Magento's got a function in lib/Mage/Archive/Helper/File.php as public function open($mode = \'w+\', $chmod = 0666) that causes all the griefer goodness. A way around it is to run Magento's Cleanup tool referenced midway down this recommended permissions settings page. – Fiasco Labs Aug 17 '13 at 20:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy