0

I'm running Elasticsearch 7.6 on my Cloudways staging server, and 7.8 with Homebrew on my local server. Using Magento 2.4 (now 2.4.1).

When I try to reindex, I see

Catalog Search index process unknown error:
{"error":{"root_cause":[{"type":"mapper_parsing_exception","
reason":"analyzer [sku] not found for field [sku]"}],
"type":"mapper_parsing_exception","reason":"analyzer [sku] not found for field [sku]"},"status":400}

When I click on test connection under catalog > search, it says successful, and my Mirasvit search plugin says that I'm connected

Any idea of what this could be?

Thanks

1 Answer 1

1

I had the same issue when using Mirasvit Search Ultimate on version 2.0.9, update to version 2.0.10 which was released on the 20th October 2020 and this resolved the issue for me.

https://mirasvit.com/docs/module-search-ultimate/current/changelog

3
  • Thanks. I upgraded, and the error is gone. They still haven't fixed the pagination issue, which means that my customers are getting a lot of 524 errors while search tries to put sometimes 2k+ products onto a page...
    – web master
    Oct 22, 2020 at 12:54
  • @webmaster I've not got a pagination issue with the site I use the extension on so maybe that is something else. Oct 23, 2020 at 13:13
  • Did you upgrade to Magento 2.4 yet? When I messaged Mirasvit, they said that they they know of the issue, and they're fixing it
    – web master
    Oct 23, 2020 at 13:23

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.