I have translated "You can create an account after checkout." text and "Place order" button and the translation is displayed correct when Magento is set to developer mode, but when switching to default mode it goes back to the previous translation.

I have tried this:

rm -rf pub/static/; rm -rf var/view_preprocessed/; rm -rf generated/; rm -rf var/cache/; rm -rf var/page_cache/*

bin/magento setup:upgrade

bin/magento setup:di:compile

bin/magento setup:static-content:deploy en_US nb_NO -f

bin/magento cahce:flush

But the translation still does not change on frontend. I am all out of ideas, anyone experienced this before? Since the translation shows in developer mode it must be some cache/static files that is not updated?

2 Answers 2


Try in incognito mode, some translations are stored in browser cache

  • Inkognito does not either, still the same issue.
    – Robert
    Oct 16, 2020 at 10:31

Solution found. The store is using Amasty One Step Checkout, disabling built in JS and HTML bundling solved the issue. Seems it is not flushed with Magento native files.

Backend settings checkout

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.