3

I'm trying to run my message queue consumer in a cronjob but the process never exits which means my cronjob never exits either. Looking at the docs https://devdocs.magento.com/guides/v2.3/config-guide/prod/config-reference-envphp.html#consumers_wait_for_messages it seems possible to turn off waiting for processes but I've tried that without success. I also tried adding it on the highest level:

cat app/etc/env.php
<?php
return [
    # ...
    'consumers_wait_for_messages' => 0,
    'queue' => [
        'consumers_wait_for_messages' => 0
    ]
];

I'm running the consumer like this: bin/magento queue:consumers:start consumer.ga.event.refund. And I've tried setting the CONFIG__DEFAULT__SYSTEM__CRON__CONSUMERS__USE_SEPARATE_PROCESS env variable that I found while googling to both 1 and 0, but it doesn't change anything.

Any advice regarding this?

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.