0

When I tried to deploy static content I am getting error on command line that ' Area code not set: Area code must be set before starting a session.'.

Deploy using quick strategy
frontend/Magento/blank/en_US            2459/2459           ============================ 100% %  1 sec
adminhtml/Magento/backend/en_US         2328/2328           ============================ 100% %  1 sec
frontend/TemplateMonster/theme059/en_US 2548/2548           ============================ 100% %  1 sec
frontend/Magento/luma/en_US             2475/2475           ============================ 100% %  1 sec


[Magento\Framework\Exception\SessionException]
Area code not set: Area code must be set before starting a session.



[Magento\Framework\Exception\LocalizedException]
Area code is not set

Can some please help me on this.

Magento version 2.2.4

After @amitshree suggestion I have run command in verbose mode, and still I am getting the same error but on different line.

Processing file '/home3/thermx2futurismd/public_html/vendor/magento/theme-frontend-luma/Magento_CustomerBalance/web/css/source/_module.less'  for area 'frontend', theme 'Magento/luma', locale 'default'module 'Magento_CustomerBalance'

.

[Magento\Framework\Exception\SessionException]
Area code not set: Area code must be set before starting a session.
3
  • Try to run your command in verbose mode and you might see some error. Use -vvv at the end of your command. May be any custom module is causing issue.
    – amitshree
    Oct 5, 2020 at 14:29
  • @amitshree, hey thank you for quick response. How can I know which custom module causing the issue? Oct 5, 2020 at 14:35
  • You can start disabling them one by one to figure it out. Disable one and test your command. Does it fix the issue? No? Disable next and test again.
    – amitshree
    Oct 6, 2020 at 6:16

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.