our product detail pages (bundle products) load very slowly (10-20 seconds, most of it is scripting time). There is no caching (FPC is enabled) and every time the page is reloaded, the complete scripting including the price calculation of all 500 bundle item is carried out anew. I followed all other tips (script bundling, minifying, gzipping, production mode, ..).

Does anyone have any idea how to enable caching here (or how to speed this scripting up)? The following is used: Magento 2.1.0 CE. Has there been any progress in this regard in a newer version?

Thanks for every tip!

1 Answer 1


At first, you need to check if your FPC is fully working or not. You will find in the browser(Network section) X-Magento-Cache-Debug: HIT. in development mode.

Please check with Mage profiling to find out which block is taking the max time. Its another way of debugging.

  • Thanks for your answer! Network stats say that html file (bundle product page) has "X-Magento-Cache-Debug: HIT." in response header. After recording network activity (Chrome network section): 189 requests 1.4 MB transferred 4.5 MB resources Finish: 25.05 s DOMContentLoaded: 1.38 s Load: 2.33 s I have enabled the Magento 2 profiler by editing the .htaccess, output is html. Loading the page just time values under 1 sec (magento 0.064712, ...) appear in the footer profiler section of the page. I am now trying "Adding Custom Profiler in specific code". Results will follow...
    – g4g4
    Commented Oct 7, 2020 at 3:58
  • I recorded performance in Chrome DevTools: 83 msLoading 5584 msScripting 115 msRendering 9 msPainting 362 msSystem 423 msIdle 6576 msTotal Following the ativity of most total time it's "initPriceBundle": 3591.1 ms
    – g4g4
    Commented Oct 7, 2020 at 4:14
  • Do you have a tip where to place the custom profiler code snippets (start / stop) to identify the performance issue? I'm really struggling here. :´-(
    – g4g4
    Commented Oct 7, 2020 at 6:59
  • Add $_SERVER['MAGE_PROFILER'] = 'html'; at the beginning of index.php file. Commented Oct 7, 2020 at 7:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.