0

We are getting the below message just after lots of integration tests already ran properly.

How can this be caused?

Configuration: /var/www/dev/tests/integration/phpunit.xml
II.........................EE.EE.                                 33 / 33 (100%)
Time: 2.45 minutes, Memory: 881.91MB
There were 4 errors:
1) Example\Foo\Test\Integration\CustomerDeactivationTest::testBar
Magento\Framework\Exception\LocalizedException: The configuration file has changed. Run the "app:config:import" or the "setup:upgrade" command to synchronize the configuration.

Edit It seems to happen because we use

$this->login();
$this->getRequest()->setMethod(Http::METHOD_POST);
$this->dispatch('customer/account/deactivate');

In the integration test...

1 Answer 1

1

The problem was in incomplete bootstrapping of the integration tests (aborted with errors), on the second run the bootstrapping worked, but only because it already was half installed - but the config stuff did not fully work then.

1
  • I my case, the bootstrapping worked. However, the test did not pass
    – kolaente
    Commented Oct 1, 2021 at 10:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.