0

Situation: Magento 2 upgrade from 2.3.5 to 2.4 not working via composer - php is already at version 7.4 before the upgrade!

These commands executed fine

COMPOSER_MEMORY_LIMIT=8G composer remove magento/product-community-edition --no-update

COMPOSER_MEMORY_LIMIT=8G composer require magento/product-community-edition=2.4.0 --no-update

And we needed to remove 1 package that had php stability as ~7.3

COMPOSER_MEMORY_LIMIT=8G composer remove package/package --no-update

BUt now we see (shortened here, but repeated vesion numbers like

tig/postnl-magento2 1.9.4.1 requires magento/framework

magento/framework 102.0.5-p2 requires php ~7.1.3||~7.2.0||~7.3.0 -> your PHP version (7.4.10) does not satisfy that requirement.

So it would seem we cannot upgrade due to? magento/framework? in it's composer file I can see

    "require": {
        "php": "~7.1.3||~7.2.0||~7.3.0",

Also I can see tig/postnl-magento2 has in it's composer file I can see

        "php": "~7.0|~7.1|~7.2|~7.3",
        "ext-soap": "*",
        "magento/framework": ">=100.1.0,<=100.1.18|>=101.0.0,<=101.0.11|~102.0",

question: is there a way to work around these 2 limiting dependencies? And also: how come the magento/framework does not want to upgrade if M2.4 is based on php 4.0 ....

Help appreciated

0

Late answer, but you have to downgrade PHP to 7.3, do the Magento upgrade and then upgrade PHP back to 7.4.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.