0

I am trying to upgrade to Magento 2.4 but I get the following error running composer update:

    - magento/framework 101.0.0-rc21 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.0-rc22 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.0-rc23 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.0-rc30 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.0 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.1 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.2 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.3 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.4 requires php 7.0.2|7.0.4|~7.0.6|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.5 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.6 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.7 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 102.0.0 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 102.0.1 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.8 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 102.0.2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.9 requires php ~7.0.13|~7.1.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.10 requires php ~7.0.13|~7.1.0|~7.2.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 102.0.2-p2 requires php ~7.1.3||~7.2.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - magento/framework 101.0.11 requires php ~7.0.13||~7.1.0||~7.2.0 -> your PHP version (7.3.7) does not satisfy that requirement.
    - mageworx/module-layered-navigation-meta 1.2.8 requires mageworx/module-layered-navigation 1.2.8 -> satisfiable by mageworx/module-layered-navigation[1.2.8].
    - mageworx/module-layered-navigation-meta 1.2.8 requires mageworx/module-layered-navigation 1.2.8 -> satisfiable by mageworx/module-layered-navigation[1.2.8].
    - mageworx/module-layered-navigation 1.2.8 requires magento/framework >=101.0.0 <103 -> satisfiable by magento/framework[102.0.5-p2, 102.0.4-p2, 102.0.5, 102.0.4-p1, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 102.0.2, 101.0.8, 102.0.1, 102.0.0, 101.0.7, 101.0.6, 101.0.5, 101.0.4, 101.0.3, 101.0.2, 101.0.1, 101.0.0, 101.0.0-rc30, 101.0.0-rc23, 101.0.0-rc22, 101.0.0-rc21].
    - mageworx/module-layered-navigation 1.2.8 requires magento/framework >=101.0.0 <103 -> satisfiable by magento/framework[102.0.5-p2, 102.0.4-p2, 102.0.5, 102.0.4-p1, 102.0.3-p1, 102.0.4, 101.0.11, 102.0.2-p2, 101.0.10, 102.0.3, 101.0.9, 102.0.2, 101.0.8, 102.0.1, 102.0.0, 101.0.7, 101.0.6, 101.0.5, 101.0.4, 101.0.3, 101.0.2, 101.0.1, 101.0.0, 101.0.0-rc30, 101.0.0-rc23, 101.0.0-rc22, 101.0.0-rc21].
    - Can only install one of: magento/framework[102.0.5-p2, 103.0.0].
    - Can only install one of: magento/framework[102.0.4-p2, 103.0.0].
    - Can only install one of: magento/framework[102.0.5, 103.0.0].
    - Can only install one of: magento/framework[102.0.4-p1, 103.0.0].
    - Can only install one of: magento/framework[102.0.3-p1, 103.0.0].
    - Can only install one of: magento/framework[102.0.4, 103.0.0].
    - Can only install one of: magento/framework[102.0.3, 103.0.0].
    - Can only install one of: magento/framework[103.0.0, 102.0.5-p2].
    - magento/module-weee-staging 100.4.0 requires magento/framework 103.0.* -> satisfiable by magento/framework[103.0.0].
    - magento/product-enterprise-edition 2.4.0 requires magento/module-weee-staging 100.4.0 -> satisfiable by magento/module-weee-staging[100.4.0].
    - magento/magento-cloud-metapackage 2.4.0 requires magento/product-enterprise-edition >=2.4.0 <2.4.1 -> satisfiable by magento/product-enterprise-edition[2.4.0].
    - Installation request for magento/magento-cloud-metapackage >=2.4.0 <2.4.1 -> satisfiable by magento/magento-cloud-metapackage[2.4.0].
    - Installation request for mageworx/module-layered-navigation-meta 1.2.8 -> satisfiable by mageworx/module-layered-navigation-meta[1.2.8].

Running composer self-update does not help. It says You are already using composer version 1.10.13 (stable channel).
Should I remove the composer.lock file?

Help appreciated!

0

The problem is in mageworx/module-layered-navigation-meta package, which says:

mageworx/module-layered-navigation-meta 1.2.8 requires mageworx/module-layered-navigation 1.2.8 -> satisfiable by mageworx/module-layered-navigation[1.2.8].

It requires mageworx/module-layered-navigation version 1.2.8

mageworx/module-layered-navigation 1.2.8 requires magento/framework >=101.0.0 <103 -> satisfiable by magento/framework[102.0.5-p2, 102.0.4-p2,...

It requires magento/framework version >=101.0.0 and <103.0.0.

But Magento 2.4 requires magento/framework version 103.0.*

Your installed version of Mageworx Layered Navigation (1.2.8) does not compatible with Magento 2.4. The lowest version of that module which compatible with Magento 2.4 is 1.3.0. You need to upgrade that module to version 1.3.0 or above.

1
  • thanks :-), that solved the issue! – Thomas Schott Sep 24 '20 at 12:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.