0

On certain images my end user complained that the images in product detail page are missing for certain products. So, I tried to reproduce the issue. I deleted all the images from one of the product that was having problem. Added images back from admin panel and saved the product.

refresh that product page in frontend and image came back. Now I clear cache on Flush Catalog Image Cache option from admin panel, check the page again and images were again missing.

Note: this is happening with certain products only.

To get all the product images generated again, I already did

php bin/magento catalog:image:resize

But as soon as I flush catalog images, the same problem comes back.

I further investigated the problem and tried below remedies too but none of them is working for me:

sudo chmod -R 777 var/cache
sudo chmod -R 777 pub/media

I checked .htaccess file inside media folder which is there.

I did a small comparison between the product that is showing images and one that is not showing. All I find is the missing images product was having just one copy of image. So I can understand catalog cache images for certain products are not getting generated.

I am using Magento ver. 2.3.5-p1 on Ubunto 18.04 on GCP

I hope the information is sufficient for you folks to understand the error and solve it.

Tried this Solution too:

select path, value from core_config_data where path like '%water%';

and get this result:

+-------------------------------------------+---------+
| path                                      | value   |
+-------------------------------------------+---------+
| design/watermark/image_size               | NULL    |
| design/watermark/image_imageOpacity       | NULL    |
| design/watermark/image_position           | stretch |
| design/watermark/small_image_size         | NULL    |
| design/watermark/small_image_imageOpacity | NULL    |
| design/watermark/small_image_position     | stretch |
| design/watermark/thumbnail_size           | NULL    |
| design/watermark/thumbnail_imageOpacity   | NULL    |
| design/watermark/thumbnail_position       | stretch |
| design/watermark/image_imageOpacity       | 40      |
| design/watermark/image_position           | center  |
+-------------------------------------------+---------+

And I really don't know what to do with this if watermark is not there.

0

There are different scenarios for this issue to happen. One of them is the missing watermark. Run this query in the database and check if you are missing any watermark.

select path, value from core_config_data where path like '%water%';

Upload those missing images and check again the Product Page.

| improve this answer | |
  • I tried the query and result I mentioned in the question itself. Now, I really don't know what to do with this result. – Vanshita Khatri Sep 23 at 9:07
  • did u check this? – Vanshita Khatri Sep 23 at 13:05

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.